Вернуться   Андрей Панько. Заметки про Dynamics NAV > По жизни
Справка Пользователи Календарь Поиск Сообщения за день Все разделы прочитаны

По жизни Не вошедшее в раздел Navision

Ответ
 
Опции темы Поиск в этой теме
  #1  
Старый 15.08.2006, 17:52
apanko apanko вне форума
Администратор
 
Регистрация: 15.08.2006
Сообщения: 1,629
Про Excel

26.06.06Вспоминал как извлечь корень с помощью программы Excel. Оказалось, что можно использовать функцию =Степень(число;1/степень). Например Степень(8;1/3)=2.
Ответить с цитированием
  #2  
Старый 23.08.2006, 12:25
apanko apanko вне форума
Администратор
 
Регистрация: 15.08.2006
Сообщения: 1,629
Solver

Ознакомился с инструментом Solver (одна из надстроек, по русски называется "Поиск решения"). Применяется для решения задач методом перебора.

Приятное открытие. А то ведь обычно либо вручную прикидываешь, либо за уголок растягиваешь.
Ответить с цитированием
  #3  
Старый 24.11.2006, 11:19
apanko apanko вне форума
Администратор
 
Регистрация: 15.08.2006
Сообщения: 1,629
Люблю в Excel использовать функцию ВПР. Бывает, скопируешь книгу товарных операций (Navision), а там только поле с кодом товара, а хочется кроме кода видеть описание, да еще б с децимальным номером. В этом случае копируем еще и справочник товаров на отдельный лист и сортируем его по полю Товар Но.
Теперь к целевой таблице (книга товарных операций) добавляем колонку, где пишем следующую формулу: =ВПР(Искомое значение; Таблица; Номер столбца; Интервальный просмотр), где
n Искомое значение – это ссылка на ячейку с кодом товара в целевой таблице (например, А1);
n Таблица – ссылка на список товаров (например, Лист2!А1:С100, для удобства последующего растягивания преобразуем в Лист2!$А$1:$С$100).
n Номер столбца – номер столбца, из которого возвращать значения (например, на листе с таблицей товаров три колонки: первая – код, вторая – наименование, третья – децимальный номер, значит, если мы хотим получить наименование, то должны указать 2).
n Интервальный просмотр – я всегда указываю ЛОЖЬ.
Формула примет следующий вид: =ВПР(А1; Лист2!$А$1:$С$100;2;ЛОЖЬ), а лист с книгой операций получит новую колонку с наименованием товара.
Ответить с цитированием
  #4  
Старый 18.12.2006, 14:46
apanko apanko вне форума
Администратор
 
Регистрация: 15.08.2006
Сообщения: 1,629
Макрос

В один прекрасный день потребовалось над многолистовом файлом MS Excel произвести многочисленные однотипные действия (установить одинаковые параметры страницы для все страниц). Одним щелчком выполнить не удалось.

Написал супермакрос.

Код:
Sub Макрос2() For iii = 1 To Sheets.Count // для всех листов с первого по последний Sheets(iii).Select //выбираем лист Application.Run "Книга1!Макрос1" //выполняем нужные действия Next // особо трудно дался этот Next, но помог встроенный хелп. End Sub
Ответить с цитированием
  #5  
Старый 10.05.2007, 10:01
apanko apanko вне форума
Администратор
 
Регистрация: 15.08.2006
Сообщения: 1,629
время2 - время1

Временной формат, да и вообще любые форматы кроме текст и число не признаю.
Время по этой причине фиксирую как 845, 1115, 2105 т.е. целое число.
«Изобрел» формулу расчета разности времени заданного в таком формате.
=((B23-ОСТАТ(B23;100))/100*60+ОСТАТ(B23;100))-((A23-ОСТАТ(A23;100))/100*60+ОСТАТ(A23;100))
где В23 – время конца, А23 время начала. ОСТАТ – стандартная формула в Excel, для определения остатка от деления.
Ответить с цитированием
  #6  
Старый 27.01.2010, 12:15
apanko apanko вне форума
Администратор
 
Регистрация: 15.08.2006
Сообщения: 1,629
Нужно было в Экселе пометить поименовать диапазон ячеек, чтоб потом использовать.
Поименовать не трудно - выделил ячейки, а затем в поле Имя (что слева от поля Формула) ввел имя диапазона.
Естественно с первого раза ввел имя с ошибкой.
Присвоил тому же диапазону имя без ошибки. Все вроде работает, но старое имя осталось. Оно хоть нигде и неиспользуется, но я так не люблю.
Удалить имя диапазона оказалось не так просто как его создать.
Для этого нужно перейти на закладку Формула и там найти пункт Диспетчер Имен. Далее понятно.

Вот полезная ссылка благодаря, которой мне удалось избавиться от ненужного имени диапазона http://office.microsoft.com/ru-ru/ex...471201049.aspx

Что характерно - ссылка находится на сайте Microsoft. Очень толково.
А вот хелп от того же Microsoft Excel - совершенно не помог.
Ответить с цитированием
  #7  
Старый 21.01.2012, 17:43
apanko apanko вне форума
Администратор
 
Регистрация: 15.08.2006
Сообщения: 1,629
Закрутился и забыл рассказать, о том что в журнале NAV4U опубликовано аж три статьи про Excel

Dynamics NAV + Office Excel = Платформа Microsoft
Извлечение данных Dynamics NAV через прямое подключение к SQL Server
Полезные приемы при работе с Microsoft Excel для пользователя Dynamics NAV
Ответить с цитированием
  #8  
Старый 21.01.2012, 17:50
apanko apanko вне форума
Администратор
 
Регистрация: 15.08.2006
Сообщения: 1,629
А теперь про задачку: Есть таблица, где в ячейке написан пользователь Иванов Иван. А мне его грузить надо в два разных столбца. Вопрос - как преобразовать данные?
Я завел три столбца. Первый - вспомогательный. Он говорит, где первый пробел.
Второй и третий - Фамилия и Имя соотвественно, т.е. значение ДО и После пробела (помним, про технический столбец).



И использовал такие формулы:

Для технического столбца, он под буквой С:
=ЕСЛИ(ЕОШИБКА(НАЙТИ(" ";B4));ДЛСТР(B4);НАЙТИ(" ";B4))
где B - это солбец с Фамилия+Имя.

Для фамилии, она под буквой D:
=ЛЕВСИМВ(B4;C4-1)
где B - столбец с Фамилия+Имя, а С - технический столбец.

Для имени, оно под буквой Е
=ПРАВСИМВ(B4;ДЛСТР(B4)-C4)

В целом ничего особенного. Но понадобилась обработка ошибок, на тот случай если у пользователя только Фамилия, а имени нет.
Собственно такой же прием можно использовать и для разбиения поля ФИО. Но делать в два захода, сначала отделить фамилию. А потом разбивать имя и отчество.
Ответить с цитированием
  #9  
Старый 30.06.2012, 11:34
apanko apanko вне форума
Администратор
 
Регистрация: 15.08.2006
Сообщения: 1,629
Цитата:
Сообщение от apanko

Для технического столбца, он под буквой С:
=ЕСЛИ(ЕОШИБКА(НАЙТИ(" ";B4));ДЛСТР(B4);НАЙТИ(" ";B4))
где B - это солбец с Фамилия+Имя.

Для фамилии, она под буквой D:
=ЛЕВСИМВ(B4;C4-1)
где B - столбец с Фамилия+Имя, а С - технический столбец.

Для имени, оно под буквой Е
=ПРАВСИМВ(B4;ДЛСТР(B4)-C4)
Поправил чутка:


Тех столбец (B)
=ЕСЛИ(ЕОШИБКА(НАЙТИ(" ";A2));ДЛСТР(A2)+1;НАЙТИ(" ";A2))

Фамилия
=ЛЕВСИМВ(A2;B2-1)

Имя
=ЕСЛИОШИБКА(ПРАВСИМВ(A2;ДЛСТР(A2)-B2);"")
Ответить с цитированием
Ответ


Опции темы Поиск в этой теме
Поиск в этой теме:

Расширенный поиск

Ваши права в разделе
Вы не можете создавать темы
Вы не можете отвечать на сообщения
Вы не можете прикреплять файлы
Вы не можете редактировать сообщения
BB-коды Вкл.
Смайлы Вкл.
[IMG] код Вкл.
HTML код Выкл.


Часовой пояс GMT +4, время: 05:28.

Контакты: e-mail, телефон: +7(926)1805967 - Архив - Вверх

Microsoft Most Valuable Professional
vBulletin v3.5.4, Copyright ©2000-2018, Jelsoft Enterprises Ltd.
Русский перевод: zCarot, Vovan & Co
Права на все материалы, опубликованные на блогофоруме принадлежат Андрею Панько, если в самом материале не указано иное.
Рейтинг@Mail.ru Rambler's Top100